Dedicated To The Smallest Of Skiffs banner

1 - 18 of 18 Posts

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #1 ·
I know this is a loaded question. But my bilge pump went out on my last trip and I've started researching what to replace it with. Currently I have an 1,100 gph unit with a separate float. I don't know what the make is but it was new about 5 years ago and my mechanic installed it. I have a switch for manual
The first make I looked at was Rule but all the reviews where not good in general. And I have to decide internal float or automatic spinner. I know you can spend as much as you want on one but I'm pretty sure I can stay under $100
 

·
Registered
Joined
·
343 Posts
I have always run Rule pumps and float switches on my boats.
SIZE - the biggest you can get to fit. The Queen Mary can sail with 100,000 gallons in her hull, You Can Not. Get it out as quick as you can.
A spare backup pump and hose with a set of battery clips is good insurance that does not take up much space or weight.

One of the best pump ever is..... A Scared Man With a Bucket !
 

·
Registered
Joined
·
136 Posts
I've always used Rule pumps without problems and always have 2, side by side, JIC.....and no bends in the output. 2 - 1,000 gph pumps throw a "lot" of water, tho' I do think their 1,000 gph brag is some optimistic. I like to set mine in the plastic filter cups/screens that are used on swamp cooler pumps to keep debris out of the pump. Doesn't take much to clog them up. (have you ever looked at the tiny impellers in those things ?? Amazing they can throw so much water)
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #4 ·
I've always used Rule pumps without problems and always have 2, side by side, JIC.....and no bends in the output. 2 - 1,000 gph pumps throw a "lot" of water, tho' I do think their 1,000 gph brag is some optimistic. I like to set mine in the plastic filter cups/screens that are used on swamp cooler pumps to keep debris out of the pump. Doesn't take much to clog them up. (have you ever looked at the tiny impellers in those things ?? Amazing they can throw so much water)
Thanks man yea my current pump could clear the bilge fast. I saw some bad reviews on Rules but who knows
 

·
Registered
Joined
·
796 Posts
I did what Ducknut suggested. I have 2 pumps, one manual and one automatic. The auto is hot wired direct to battery so that it comes on no matter where it is. A boat will catch a lot of rain water tied to a dock or running down the road. Thankfully I've never had to use neither.
I'm running Attwood pumps and check them periodically.
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #8 ·
Keep a bucket in the boat for a manual bilge.
I keep a white 5 gallon bucket next to my console. Has a cast net and anchor in it. I can use it to bail or a saltwater bathroom
 

·
Registered
Joined
·
4,733 Posts
Since my old Maverick is not self bailing... I have two pumps installed as above (one with a float switch and the usual three way switch)- - the other strictly manual. Both are Rule 1100’s and they’re entirely separate with different power sources, fuses, switches, wiring, and hoses... even different through hulls...

By the way, those two pumps have been in place for years - and still going strong. Whenever there’s a problem it’s always a fuse, switch, or wiring issue - never the pump... Highly recommend the Rule standard 1100 pump
 

·
Registered
Joined
·
185 Posts
I use tsunami Atwood 800 gph and change both bait well and bilge pumps every two years. I use a quick disconnect clip so I don’t need to cut wires etc if they fail on the water. I’m running a Beavertail Vengeance and these pumps do the job. Good idea to rinse the bilge with cleaner monthly too.
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #11 ·
I use tsunami Atwood 800 gph and change both bait well and bilge pumps every two years. I use a quick disconnect clip so I don’t need to cut wires etc if they fail on the water. I’m running a Beavertail Vengeance and these pumps do the job. Good idea to rinse the bilge with cleaner monthly too.
That's a good idea. I'll look into that
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #12 ·
I went my boat today between rain showers. My goal was to find out which bilge pump I had and measure the hose so I could get a new one. Well while lifting it out the float switch hit and the pump came on. I was surprised it came on with the power turned off but that's what it's supposed to do. It's a Tusami 1,200 gph. The hose is over an inch. I put the plug in and tried to fill it with the garden hose. Of course it pumped it out as fast as I put it in
Now when we where coming back to the dock 2 weeks ago it did not work. We turned on the switch on the dash and no noise. Today everything work. I don't have a clue what happened
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #13 ·
Bump. I think it may be the switch but not sure
 

·
Registered
Joined
·
707 Posts
I know this is a loaded question. But my bilge pump went out on my last trip and I've started researching what to replace it with. Currently I have an 1,100 gph unit with a separate float. I don't know what the make is but it was new about 5 years ago and my mechanic installed it. I have a switch for manual
The first make I looked at was Rule but all the reviews where not good in general. And I have to decide internal float or automatic spinner. I know you can spend as much as you want on one but I'm pretty sure I can stay under $100
Never scrimp on bilge pumps or tow vehicle tires.
 

·
Registered
Joined
·
4,733 Posts
What you've described is something I've been through many times (and it's the chief reason I have two pumps, separately wired, switched, fused, powered, etc). In short don't replace the pump without pulling it and checking it by touching the wires to a good power source (I use my truck's battery...). Here's the deal - most of the time it's your wiring, fuse, or switch that's bad - not your pump... at least that's been my experience...

Any competent marine electrician can check your pump circuit in just a minute or two - and usually find a bad wire or a bad connection somewhere. When you go day after day the way most guides do in season you're going to wear things out and/or have corrosion problems sooner rather than later in my experience. Having that back-up pump installed has saved me many a trip over the years -- but you still have to troubleshoot any system that's not working for you (another of those "ask me how I know" routines...). Either do it yourself or find a skilled tech to sort it out for you....

Aren't boats fun?
 

·
I Love Skinny Water
Joined
·
6,062 Posts
Discussion Starter · #17 ·
I'm replacing the switch first then work back.
 

·
Registered
Joined
·
373 Posts
Check the in line fuse also because sometimes the solder where the leads attach to the fuse corrode and that will cause an intermittent connection until it opens up all the way. They are covered with an insulator so it is hard to see unless you remove the fuse and look.
 
1 - 18 of 18 Posts
Top