Dedicated To The Smallest Of Skiffs banner

1 - 20 of 23 Posts

·
Registered
Joined
·
473 Posts
Discussion Starter · #1 ·
Been planning this trip to rockport for a while! Get there and my trim is messed up. Struggles to go up and sometimes even not going up at all. Anything I should look like on my own? Will still try to go fish but would be happier going skinnier. Help!!!!
 
G

·
Need a better explanation. Is it chattering, relay clicking, straining, etc... If you are assuming electrical then I would have to say check and clean all of your grounds and connections.
 

·
Registered
Joined
·
473 Posts
Discussion Starter · #3 ·
BB - Weird straining and whizzing noise coming from the hydraulic pump area. Going up. Down does not seem to be a challenge
 

·
Registered
Joined
·
473 Posts
Discussion Starter · #5 ·
Hmmm ... seems right! will google it but can you point me in the right direction to the manual release valve?
 
G

·
Down low on the clamp bracket, I believe starboard side you should see an opening. In that opening will be what looks like a largish flathead screw. Tilt the motor all the way up, loosen screw and allow motor to slowly go all the way down, re tighten the valve and try it.
 

·
Registered
Joined
·
473 Posts
Discussion Starter · #10 ·
BB - when I went to check for the valve this morning, I saw that I am slowly bleeding hydraulic fluid
 
G

·
If it’s the manual release valve then it is a pretty straight forward repair. Remove old “have drain pan under to catch oil”. Replace, fill with fluid, done.
 

·
Registered
Joined
·
473 Posts
Discussion Starter · #13 ·
It is coming from the top of the block. Let’s try
 

·
Registered
Joined
·
4,734 Posts
Sad to say- what's probably going on is your hydraulic ram is leaking - and needs to be re-built... Any competent outboard shop can do the job - but bring your checkbook....

It would be nice if all that's going on is a leaking release screw - but I doubt it... Just another one of those "ask me how I know" propositions since mine needed re-building last years (2012 E-Tec 90....).
 
G

·
It is coming from the top of the block. Let’s try
Sad to say- what's probably going on is your hydraulic ram is leaking - and needs to be re-built... Any competent outboard shop can do the job - but bring your checkbook....

It would be nice if all that's going on is a leaking release screw - but I doubt it... Just another one of those "ask me how I know" propositions since mine needed re-building last years (2012 E-Tec 90....).
Top of the cylinder? I think the capt. Is probably right unfortunately.
 

·
Banned
Joined
·
1,441 Posts
Mine was air locked once ,stored in raised position. A little compressed air, very little , Watch for blow back, got fluid to the needed area , added fluid No trouble since.
 

·
Registered
Joined
·
473 Posts
Discussion Starter · #17 ·
It is right at the hydraulic ram
 
G

·
Yep, time for a seal kit or rebuild. If it’s not leaking bad, you can top it off and get by most likely and have done when you get back.
 
1 - 20 of 23 Posts
Top