Dedicated To The Smallest Of Skiffs banner
1 - 6 of 6 Posts

· I Love microskiff.com!
Joined
·
3,082 Posts
Discussion Starter · #1 ·
I have an ongoing problem with my MFD--doesn't read depth underway at all, and provides depth readings on and off while running off plane, etc. What could be causing this?
 

· Registered
Joined
·
6 Posts
My new Evo3 did not read temp or depth. After several phone attempts with Simrad, I took back to dealer who installed on new boat. They got both depth and temp displaying in instrument bar for both chart and sonar. First time out since, displaying depth goes in and out without any rhyme or reason. It will read for a while and then quit for a while. Only installed Simrad on new boat to use the FMT card, which I absolutely love! Boat on way back to Dealer to either fix or remove off boat.
 

· Registered
Joined
·
353 Posts
The transducer is very sensitive to proper install height and location. If its off just a little it can read inconsistent. Mine reads at 50 mph with no issues. Expect several minor height adjustments before its dialed in. Its rarely right the first time.
 

· I Love microskiff.com!
Joined
·
3,082 Posts
Discussion Starter · #5 ·
My new Evo3 did not read temp or depth. After several phone attempts with Simrad, I took back to dealer who installed on new boat. They got both depth and temp displaying in instrument bar for both chart and sonar. First time out since, displaying depth goes in and out without any rhyme or reason. It will read for a while and then quit for a while. Only installed Simrad on new boat to use the FMT card, which I absolutely love! Boat on way back to Dealer to either fix or remove off boat.
Sounds like the same issues I am experiencing.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top