Dedicated To The Smallest Of Skiffs banner

1 - 5 of 5 Posts

·
Registered
Joined
·
655 Posts
Discussion Starter · #1 ·
Found a 2005 for a helluva deal. But knew there had to be something amiss.

Engine start fine.
Compression is good

There got to be something wrong with it......
It's not peeing.

Tried the weed eater line, pulled the tube from the block. Still nada. I'll blow some air with a compressor later to see if that helps.

Impeller? Thermostat?
Where do I start? Where can I get a manual?
Are they online anywhere?
I started to do a search but wanted to start a thread to keep a log (hopefully short) of the trouble shoot.
I'd prefer to do everything my self and learn the ins and outs of this motor.
 

·
> PRO STAFF <
Joined
·
7,520 Posts
Part No. 826883R03 Shop Manual O/B 20-25 &JET  1 Info  $74.95
http://www.crowleymarine.com/mercury_parts/11407/0.cfm

As I've said before, any time I buy a used motor,
I treat it like it's never been serviced and do it all.

previous post...

http://www.microskiff.com/cgi-bin/yabb2/YaBB.pl?num=1249362026/1#1
 

·
Registered
Joined
·
655 Posts
Discussion Starter · #3 ·
Compressor blast solved it. Had some sand or mud up in there. Peeing like a race horse now. So happy.
Brett, RK thx for the info.
 

·
just try to follow me....i dare ya...
Joined
·
528 Posts
i know this is after the fact, but ive just read it....

remember a 2stroke 25 merc wont pee till it gets warmed up and the thermostat opens up...
 

·
Brandon, FL
Joined
·
10,798 Posts
On a lot of Merc's there is a rubber grommet attached to the top of the intake tube where it enters the block and sometimes corrosion grows there and pinches the grommet closed restricting the water flow.
 
1 - 5 of 5 Posts
Top