Dedicated To The Smallest Of Skiffs banner

1 - 8 of 8 Posts

·
I Love microskiff.com!
Joined
·
55 Posts
Discussion Starter #1
Ok. The first thing that got my attention whn I bought my boat 2 years ago was that the Tach did not work. I have also noticed that I get little to no charge to my battery. I replaced the tach, but that didn't do any good. Now that I have done some research, I realize that the tach was probably fine and that it could be a rectifier/regulator problem or a stator issue. here is what I have done/found so far. I replaced teh rectifier/regulator. It is the 6 wire style. This did no good. I then noticed that the two yellow wires that come from teh Stator to the Rectifier were fried at the connections on either end. I replaced them, and still no dice. Is the last step to replace the stator? Is there a way to test it? Any help would be appreciated.

Thanks
 

·
> PRO STAFF <
Joined
·
7,516 Posts
Check your wiring against the merc color codes
to verify the intended circuit function, yellow is charging circuit
grey is tach function...

http://www.maxrules.com/fixmercwiringcodes.html
 

·
Hooking Lips is my life
Joined
·
199 Posts
I had to replace the stator on mine due to no power because one cylinder wasnt firing so YES it will still run.
If your stator was fried I don't believe the motor would work at all...
 

·
I Love microskiff.com!
Joined
·
55 Posts
Discussion Starter #5
Thanks Brett,

My wiring all looks good. That is to say, I have connected the new rectifier in the exact manner the original one was. Any ideas why the yellow wires would have been burned up at either end?
 

·
Hooking Lips is my life
Joined
·
199 Posts
hooked up battery charger wrong or wrong setting on charger?
Thanks Brett,

My wiring all looks good. That is to say, I have connected the new rectifier in the exact manner the original one was. Any ideas why the yellow wires would have been burned up at either end? 
 

·
devilray snob
Joined
·
2,398 Posts
I had to replace the stator on mine due to no power because one cylinder wasnt firing so YES it will still run.
If your stator was fried I don't believe the motor would work at all...
Oh, I had a fried stator in my two stroke and it would not run at all.
 
1 - 8 of 8 Posts
Top