'14 Evinrude E-Tec 115

Discussion in 'Outboard Maintenance' started by ekimmicroskiff, Apr 9, 2014.

  1. ekimmicroskiff

    ekimmicroskiff '14 EC Vantage

    125
    0
    91
    I have an Evinrude 115 hung on the back of my ECC Vantage. When I run wide open for more than 30 sec I lose 500 RPM....5200 down to 4700. Once I quickly pull back the throttle and then quickly push it back down, it goes right back to 5200 with no problem until another 15-30 secs go by and then I have to repeat the process. The motor is running smooth and on all cylinders the entire time. Any ideas? I probably have less that 15 hours on the motor so I will be calling Evinrude if I can't find an easy fix.

    Thanks,

    -Miller
     
  2. Brett

    Brett > PRO STAFF <

    Today's guess is: throttle creep caused by slightly out of adustment cable. :-?
     

  3. tortuga

    tortuga Well-Known Member

    78
    2
    331
    sounds like you have a fuel restrictions. you need to watch your primer bulb and see if its collapsing when that rpm loss occurs. and you can take it back to where you got it from and get it fixed
     
  4. ekimmicroskiff

    ekimmicroskiff '14 EC Vantage

    125
    0
    91
    Thanks guys! I will look for both of those.

    -Miller
     
  5. mirrocraft

    mirrocraft I Love microskiff.com!

    147
    0
    341
    5200rpm is way low for that motor. Seems low.
     
  6. ekimmicroskiff

    ekimmicroskiff '14 EC Vantage

    125
    0
    91
    At the end of last summer I re-propped the motor with a 3 blade Viper 13 7/8 x 15 (from a 13 x 17, 4 blade Rouge) and changed to the Evinrude XD100 oil setting. The RPM loss seemed to go away for a couple of trips, but I was never able to get above 5200 without trimming way up to the point where the boat starts to porpoise. I changed jobs and was unable to get on the water last fall and winter. Last week spent 4 days in the keys and the RPM issue has returned. I think this is a motor issue. Boat is at the shop...will let everyone know what I find.
     
  7. ekimmicroskiff

    ekimmicroskiff '14 EC Vantage

    125
    0
    91
    I spoke with the Evinrude service tech today. He tells me that there is a service bulletin on the E-Tec 115 regarding loss of mid range RPMS and it basically describes my exact issue. The fix is to update the Onboard Computer software. hopefully this fixes the issue.
     
  8. ekimmicroskiff

    ekimmicroskiff '14 EC Vantage

    125
    0
    91
    Ran the boat this weekend...the software update fixed the issue.