Dedicated To The Smallest Of Skiffs banner
1 - 6 of 6 Posts

·
Sand Flats
Joined
·
14 Posts
Discussion Starter · #1 ·
A few weekends back , was out fishing and had trouble starting the motor . Got it to started and started running when all of a sudden I heard a pop and slapping . Like a fan belt breaking and slapping around .
Got towed by a very nice fishing guide that had a charter whith him at the time .
As I am un hitching the boat at the dealer I see my that my hub blew out . Good thing I made it there .
Got a call today saying the boat was ready .
A fuel injector blew up . Thay had never seen that before .
Water test this weekend if all goes well and I don't have to work .
Could water in the fuel cause this ? I have a separator .
 

·
Sand Flats
Joined
·
14 Posts
Discussion Starter · #4 ·
Just picked it up and thay still can't figure out what happen . Thay even called Tohatsue to akk if this has happened before . Thay said thay would look into it .
Oo well , that part of owning a boat .
 

·
Sand Flats
Joined
·
14 Posts
Discussion Starter · #5 ·
Just picked it up and thay still can't figure out what happen . Thay even called Tohatsue to akk if this has happened before . Thay said thay would look into it .
Oo well , that part of owning a boat .
 

·
Sand Flats
Joined
·
14 Posts
Discussion Starter · #6 ·
Update :
It ran !
Smoked a lot and flet like it did not have power . It even sounded different . Ran from the boat ramp to South Bay ( the furtherst South you can go . The tip of Texas ) 3 mile run . Fished for a couple of hours and put a 24 and 23" Red Fish in the dinner box .
Started her up and it sounded a lot better and had full power again . The computer must have rest it self . Ran fine after that . She how she dose tomorrow . Going to run 30 miles North on the sand flats .
[smiley=chicken.gif] [smiley=chicken.gif] [smiley=chicken.gif] [smiley=chicken.gif] [smiley=chicken.gif]
 
1 - 6 of 6 Posts
Top